WP Robot Support Forum


WP Robot Support Forum » WP Robot Support

Cloaking doesn't work

(4 posts)
  1. I activated the cloaking feature in the Options panel and set up my htaccess file. Here is the script of my htaccess file:

    # BEGIN WordPress

    # WP Robot Link Cloaking START
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^go/([^/]*)/([0-9]+)/([0-9]+)/?$ http://www.stopmigrainesymptoms.com/wp-content/plugins/WPRobot3/cloak.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule ^go/([^/]+)[/]?$ http://www.stopmigrainesymptoms.com/wp-content/plugins/WPRobot3/cloak.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    # WP Robot Link Cloaking END

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Options +FollowSymLinks
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^stopmigrainesymptoms\.com
    RewriteRule ^(.*)$ http://www.stopmigrainesymptoms.com/$1 [R=permanent,L]

    I also checked and there is a cloak.php file in my WPRobot3 plugins folder on my server.

    None of the affiliate links are cloaked.

    Any suggestions?

    Posted 4 years ago #
  2. lunatic
    Key Master

    I had a look at your website and the affiliate links do appear to be both cloaked and working, i.e. like this url from one of the Amazon images on your site: http://www.stopmigrainesymptoms.com/go/link/127/2.

    Posted 4 years ago #
  3. I'm glad it's working for you.

    I tried on another computer and it went to my cloaked url, then redirected to amazon.

    Also, I clicked on the link you listed in your post and got a 404 error.

    Any ideas?

    Paul

    Posted 4 years ago #
  4. lunatic
    Key Master

    It is normal that the cloaked links redirect to Amazon - that is their purpose, cloaking only affects the url on your own site.

    The 404 error is because of the "." at the end of the url here.

    Posted 4 years ago #

RSS feed for this topic

Reply

You must log in to post.