Strict Standards: Declaration of BB_Walker_Blank::start_lvl() should be compatible with BB_Walker::start_lvl($output) in /www/htdocs/w00b72dc/forum/bb-includes/classes.php on line 1170

Strict Standards: Declaration of BB_Walker_Blank::end_lvl() should be compatible with BB_Walker::end_lvl($output) in /www/htdocs/w00b72dc/forum/bb-includes/classes.php on line 1170

Strict Standards: Declaration of BB_Walker_Blank::start_el() should be compatible with BB_Walker::start_el($output) in /www/htdocs/w00b72dc/forum/bb-includes/classes.php on line 1170

Strict Standards: Declaration of BB_Walker_Blank::end_el() should be compatible with BB_Walker::end_el($output) in /www/htdocs/w00b72dc/forum/bb-includes/classes.php on line 1170

Strict Standards: Redefining already defined constructor for class bbdb in /www/htdocs/w00b72dc/forum/bb-includes/db-mysql.php on line 12
ebay module cloaking doesnt work « WP Robot Support Forum

WP Robot Support Forum

Forum Closed

Please note the support forum has been closed and all support for WP Robot is handled via email now as we have found this to be more effective. The forum will remain online to allow access to old answers.

Please use the contact form here to get in touch regarding any questions or problems you might have.


WP Robot Support Forum » WP Robot Support

ebay module cloaking doesnt work

(6 posts)

Tags:

  1. mrpops
    Member

    hello.
    i am running both 2.12 and latest v3 on my blogs,i just recently was accepted in ebay affiliates.
    When I click on "bid now" link in the post it redirecting me back to my site.

    What could it be?How can I fix that?
    P.S. checked on on posts made with 2.12

    Posted 6 years ago #
  2. mrpops
    Member

    forgot to mention , htaccess file is correct,according to instructions

    Posted 6 years ago #
  3. lunatic
    Key Master

    Did you update the htaccess after installing WP Robot 3 (as ebay links were not yet cloaked in v2)?

    Posted 6 years ago #
  4. mrpops
    Member

    htaccess was updated automaticly (i noticed another group of wprobot cloaking code added )

    Besides , amazon and clickbank cloaking works perfectly fine ,the only ebay module doesn't.It re-directs back to index page.
    Below my htaccess file

    ----------

    RewriteEngine on
    #Options -Indexes#
    # WP Robot Link Cloaking START
    <IfModule mod_rewrite.c>
    RewriteRule ^go/([^/]*)/([0-9]+)/([0-9]+)/?$ http://(my actual domain).com/wp-content/plugins/WPRobot/cloak.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule ^go/([^/]+)[/]?$ http://(my actual domain).com/wp-content/plugins/WPRobot/cloak.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    # WP Robot Link Cloaking END

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$

    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]

    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$

    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache

    # WP Robot Link Cloaking START
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^go/([^/]*)/([0-9]+)/([0-9]+)/?$ http://(my actual domain).com/wp-content/plugins/WPRobot3/cloak.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule ^go/([^/]+)[/]?$ http://(my actual domain).com/wp-content/plugins/WPRobot3/cloak.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    # WP Robot Link Cloaking END

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Posted 6 years ago #
  5. lunatic
    Key Master

    Please try removing the old v2 code from the htaccess like this:

    ----------

    RewriteEngine on
    #Options -Indexes#

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$

    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]

    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$

    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache

    # WP Robot Link Cloaking START
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^go/([^/]*)/([0-9]+)/([0-9]+)/?$ http://(my actual domain).com/wp-content/plugins/WPRobot3/cloak.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule ^go/([^/]+)[/]?$ http://(my actual domain).com/wp-content/plugins/WPRobot3/cloak.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    # WP Robot Link Cloaking END

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Posted 6 years ago #
  6. mrpops
    Member

    Thank you,
    It worked.

    Posted 6 years ago #

RSS feed for this topic

Reply

You must log in to post.