WP Robot Support Forum


WP Robot Support Forum » WP Robot Support

Cloaking NOT Working Why?

(26 posts)
  • Started 4 years ago by Hutchirg
  • Latest reply from mmabrawl

Tags:

  1. Hutchirg
    Member

    I went through previous question and answers here in the forum about this and it seems most were user errors....

    Below is how my .htaccess file looks. I've tick the cloak link option in WP Robot and everything looks like the documentation describes "http://mydomain.com/go/Link_Title/18/1"

    When I click the affiliate links ebay,amazon,clickbank the page just refreshes. It stay dormant on that page. No errors just refreshes.

    # WP Robot Link Cloaking START
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^go/([^/]*)/([0-9]+)/([0-9]+)/?$ http://MyDomain.com/wp-content/plugins/WPRobot/cloak.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule ^go/([^/]+)[/]?$ http://MyDomain.com/wp-content/plugins/WPRobot/cloak.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    # WP Robot Link Cloaking END

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Thanks in advance!

    Posted 4 years ago #
  2. lunatic
    Key Master

    Hm, never heard of it just staying on the same page before. What happens when you open

    http://mydomain.com/wp-content/plugins/WPRobot/cloak.php

    in your browser?

    Posted 4 years ago #
  3. anteck
    Member

    I've got the same problem.

    .htaccess is setup fine, clickbank refers over fine, eBay links do not - they just return to the post page.

    Posted 4 years ago #
  4. anteck
    Member

    And another problem...

    Some of the ebay links go to the video or story link that lie above it.

    Posted 4 years ago #
  5. Hutchirg
    Member

    Thanks lunatic for looking in at me. When I do what you suggest:

    http://mydomain.com/wp-content/plugins/WPRobot/cloak.php

    It just refreshes the page.

    Let me know if you what access to my admin area because I would like to take advance of the cloaking feature.

    Thanks in advance,

    Randy

    Posted 4 years ago #
  6. anteck
    Member

    For me, the problem is the plugin is cloaking ebay RSS links as well. Should it be doing this?

    Posted 4 years ago #
  7. lunatic
    Key Master

    anteck, no ebay rss links should not get cloaked currently. Which WP Robot version are you using and do you have WP Shopping Pages installed too?

    Hutchirg, yes, please send me a login. Maybe I can find something this way.

    Posted 4 years ago #
  8. Hutchirg
    Member

    Thank lunatic,
    I can't automatically post neither. I CAN MANUALY POST EVERYTHING!

    I can't Cloak......
    I use the plugin from 5ubliminal "Schedule M.I.A.s" still no go.
    I use the edit wp-includes/cron.php changing 0.01 -> 20 Still no go.
    I have deactivated all plugin except WP-Robot still no go

    Please see if you can spot anything.

    Lunatic, I use the "CONTACT" form below and sent you my blog info.

    Posted 4 years ago #
  9. lunatic
    Key Master

    Received, I will check your site later.

    Posted 4 years ago #
  10. anteck
    Member

    Hi Lunatic,

    I purchased WPRobot Elite.

    Version 2.10

    I have not heard of WP Shopping Page... it's not installed.

    Check out some of the cloaked links : http://digitalmarket.com.au/

    Some ebay RSS links redirect to the above story.

    Others don't go anywhere, just refresh.

    Cheers,

    Anthony.

    Posted 4 years ago #
  11. lunatic
    Key Master

    What do you have selected in the eBay Options for "Auto Renew Auctions:"?

    Posted 4 years ago #
  12. I have the same problem and have disabled cloaking to make the links work.
    Lunatic - I'm happy to email my login to let you check settings, etc if you let me know best email

    Posted 4 years ago #
  13. lunatic
    Key Master

    You can send the login here and I'll have a look: http://wprobot.net/blog/contact/

    Posted 4 years ago #
  14. Lunatic - I've sent you the login.
    When WP Robot cloaking is switched on, ebay links seem to be cloaked and send users back to a page on the same site. Switching off cloaking makes the ebay links work normally again.

    Posted 4 years ago #
  15. Kevinc24
    Member

    Im having the same problem. All Ebay Cloaked links are redirected to my home page. Any fix for this yet?

    Posted 4 years ago #
  16. I ever experienced with this kind of problem.
    The easiest way to solve this is change the permalink to default, and save it.
    Next try the website to make sure the permalinks goes to default.
    Then change again the permalinks to your previous setting.

    Usually, it works for me.

    Posted 4 years ago #
  17. I tried your sugesstion irwanbee - unfortunately the problem still persists.

    Posted 4 years ago #
  18. anteck
    Member

    What do you have selected in the eBay Options for "Auto Renew Auctions:"?

    It's on RSS Feeds.

    Looking at the other reports, this is definitely a bug.

    Posted 4 years ago #
  19. anteck - Ebay Auto Renew Auctions set to "Yes, embed RSS feed".
    (It is likely to be a bug which, I'm sure, lunatic will be working hard to resolve)

    Posted 4 years ago #
  20. lunatic
    Key Master

    Ok I finally found the reason and a fix will be released later today.

    If you want to do it yourself all you have to do is delete the lines 149-152 from ebay.php and the links will work again.

    Posted 4 years ago #
  21. tresero
    Member

    Lunatic,
    The problem with your solution is that cloaking stops for all ebay auctions. Is that intended?

    Posted 4 years ago #
  22. lunatic
    Key Master

    Yes it is. Cloaking for eBay RSS auctions was not included yet and the links being cloaked was an error. It will be added with the next update though.

    Posted 4 years ago #
  23. Forger
    Member

    On the subject of cloaking, I notice that part of the cloaked links read as "go/link/". Is there a way to change this to something else? Maybe something like "auction/item" for instance.

    The only reason I ask is that I'm worried about leaving a footprint of some kind. If I can change it to something else then it makes the links more unique and, therefore, harder for the search engines to detect.

    Is this possible?

    Posted 4 years ago #
  24. lunatic
    Key Master

    Yes, have a look at lines 397 to 431 of general.php. There are 4 instances of "go" you have to change there and you also have to change them in your .htaccess file, then it should work. Editing the "link" part would be harder.

    Posted 4 years ago #
  25. sushilgupta
    Member

    Need help!!

    I installed the WP Robot Plugin 3.0 and when the clocked URL is "http://sitename.com/wp-content/plugins/WPRobot3/cloak.php?post_id=3777&link_num=7&cloaked_url=go/link/3777/7" then it shows "Nothing found for Wp-content Plugins WPRobot3 Cloak Php?post_id=3777&link_num=7&cloaked_url=go Link 3777 7" in the result page and does not reach and execute the cloak.php file script.

    Thank you in advance.

    Posted 3 years ago #
  26. mmabrawl
    Member

    well me the clocked links lead to any website without any relation to ebay.... with the older WP robot version the auction links from ebay weren't cloacked. I try to edit ebay.php and see if it works

    Posted 3 years ago #

RSS feed for this topic

Reply

You must log in to post.